EYEBEAM - Requirements

The EyeBeam softphone is known for its vast functionalities delivering unprecedented VoIP experience to its users. Although eyeBeam is comprehensive yet an easy-to-use softphone, it doesn’t require its users to have a powerful computer for it to run. If you are looking for a softphone, either personal or for business use, then eyeBeam is definitely the right choice for you.

Eyebeam
EYEBEAM
xlite
X-LITE
bria
BRIA

 

  More Information   Overview   |  Features   |  Requirements   |  Resources


Requirements

To use eyeBeam to make audio/video calls and/or send Instant Messages to a softphone, mobile or landline number, a VoIP (Voice over IP) service subscription with a local service provider or ISP is required. Please contact your local service provider to subscribe.

System Requirements

Basic (Audio & IM) Enhanced (Audio, Video & IM)
Minimum Optimal Minimum Optimal
Processor Intel Pentium II 400 MHz or equivalent Pentium III 1.3 GHz or equivalent Intel Pentium III 700 MHz or equivalent Pentium 4 2.0 GHz or equivalent
Memory 128 MB RAM 128 MB RAM 256 MB RAM 256 MB RAM
Hard Disk Space 15 MB 30 MB 30 MB 30 MB
Operating System* Windows 2000
Windows XP
Windows Vista
Mac OS X 10.4
Mac OS X 10.5 Leopard
Mac OS X 10.6 Snow Leopard
Windows 2000
Windows XP
Windows Vista
Mac OS X 10.4
Mac OS X 10.5 Leopard
Mac OS X 10.6 Snow Leopard
Windows 2000
Windows XP
Windows Vista
Mac OS X 10.4
Mac OS X 10.5 Leopard
Mac OS X 10.6 Snow Leopard
Windows 2000
Windows XP
Windows Vista
Mac OS X 10.4
Mac OS X 10.5 Leopard
Mac OS X 10.6 Snow Leopard
Connection IP network connection (broadband, LAN, wireless); Internet connection IP network connection (broadband, LAN, wireless); Internet connection IP network connection (broadband, LAN, wireless); Internet connection IP network connection (broadband, LAN, wireless); Internet connection
Sound Adapter Full-duplex, 16-bit Full-duplex, 16-bit Full-duplex, 16-bit Full-duplex, 16-bit

* Windows Operating Systems: 32-bit OS only
Outlook dialing support/integration (eyecall.dll) is supported in Outlook 2003 only
Note - Windows 7 is not supported yet. A patch will be provided soon. You can run eyeBeam in Windows XP compatibility mode until a patch is provided.

Any Questions?

If you wish to receive further information, do not hesitate to contact us.