
CMC Bria 2.2 for Windows

User Guide



CounterPath Corporation

CounterPath Corporation.
Suite 300, Bentall One Centre
505 Burrard Street Box 95
Vancouver BC V7X 1M3
Tel: 1.604.320.3344
sales@counterpath.com    www.counterpath.com

© December 2007
This document contains information proprietary to CounterPath Corporation, and shall not be used for 
engineering, design, procurement, or manufacture, in whole or in part, without the consent of CounterPath 
Corporation.

The content of this publication is intended to demonstrate typical uses and capabilities of the CounterPath 
Multimedia Communicator Bria 2.2 softphone application from CounterPath Corporation. Users of this 
material must determine for themselves whether the information contained herein applies to a particular 
IP-based networking system.
CounterPath makes no warranty regarding the content of this document, including—but not limited to—implied 
warranties of fitness for any particular purpose.
In no case will CounterPath or persons involved in the production of this documented material be liable for any 
incidental, indirect or otherwise consequential damage or loss that may result after the use of this publication.

This manual corresponds to CMC Bria version 2.2



i

Contents
Introduction...................................................................................................................................1

What Is CMC Bria? ................................................................................................................1
Installation and Setup....................................................................................................................3

Getting Ready .........................................................................................................................3
Installing Bria .........................................................................................................................4
Configuring Bria .....................................................................................................................5

Using Bria .....................................................................................................................................9
Starting Bria ............................................................................................................................9
Shutting Down ........................................................................................................................9
The Onscreen MMC ...............................................................................................................10
Placing a Call ..........................................................................................................................12
Handling an Incoming Call.....................................................................................................16
Handling an Established Call..................................................................................................17
Transfering a Call ...................................................................................................................18
Video.......................................................................................................................................20
Voicemail................................................................................................................................21
Forwarding Calls.....................................................................................................................21
Conference Calls.....................................................................................................................22
Instant Messaging ...................................................................................................................26
Sending and Receiving Files...................................................................................................28
Email .......................................................................................................................................30
The Deskbar ............................................................................................................................30

The Address Book ........................................................................................................................31
Contacts Tab ...........................................................................................................................31
History Tab .............................................................................................................................38
Availability .............................................................................................................................39
Privacy ....................................................................................................................................45

Configuring Bria ...........................................................................................................................47
Configuring your Profile.........................................................................................................47
Configuring Preferences .........................................................................................................48
Configuring Accounts.............................................................................................................62

A Application Hot Keys ...............................................................................................................77
B Dialing Plan...............................................................................................................................79
C Contact List Headings ...............................................................................................................85
D Location of Files .......................................................................................................................87
E Other Ways to Run Bria ............................................................................................................89
F Glossary .....................................................................................................................................91



CounterPath Corporation

ii



1

1 Introduction

1.1 What Is CMC Bria?
CounterPath Multimedia Communicator Bria 2.2 is a standards-based multimedia communications 
application.With its enhanced new interface, Bria expands the softphone experience by making it even easier 
for users to make VoIP (Voice over Internet Protocol) and Video over IP calls, to share presence (availability) 
information with other users, to send instant messages, and to exchange files.

CMC Bria  implements SIP-based standards, allowing users to work with a multitude of different VoIP servers 
and service providers.

This release of CMC Bria adds support for instant messaging and presence over XMPP.

Standard Telephone Features
The CounterPath Multimedia Communicator Bria 2.2  has all standard telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold, Do Not Disturb.
• Call history – list of received, missed, and dialed calls.
• Call transfer. 
• Six-party audio conferencing.
• Three-party video conferencing.

Enhanced Features and Functions
The CounterPath Multimedia Communicator Bria 2.2 also supports the following features and functions:

• Instant messaging and presence using the SIMPLE protocol or the XMPP protocol.
• Managed contact list – importing and exporting contacts between Bria and other applications.
• File transfer via an XMPP account.
• Automatic detection and configuration of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs:

AMR Wideband (G.722.2), Broadvoice-32, Broadvoice-32 FEC, DVI4, DVI4 Wideband, G.711aLaw, 
G.711uLaw, G.723, G.726, G.729, GSM, iLBC, L16 PCM Wideband, Speex, Speex FEC, Speex Wideband, 
Speex Wideband FEC.

• Support for the following video codecs:
H.263, H.263+ 1998, H.264.
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• Automatic selection of the best codec based on the other party’s capability, the available bandwidth, and 
network conditions. Bria switches the codec within a call in response to changing network conditions.

• SIP compliance to 3261 SIP standard.
• XMPP compliance as follows:

• RFC 3920
• RFC 3921
Supported extensions:

• XEP-0004
• XEP-0016
• XEP-0022
• XEP-0077
• XEP-0085
• XEP-0092
• XEP-0115

• STUN and ICE NAT traversal. XTunnels for firewall traversal.
• Support for DTMF (RFC 2833, inband DTMF or SIP INFO messages). 
• Support for languages.



3

2 Installation and Setup

2.1 Getting Ready

SIP Accounts
After choosing a VoIP service provider, you will need the following information:

• User name
• Password
• Authorization Name (if applicable)
• Domain
• Firewall traversal and other network information; see “Configuring Accounts” on page 62.

XMPP Accounts
If you use an XMPP service for instant messaging or presence, you will need the following information:

• Jabber ID: user name and domain. For example, jsantos@domainXMPP.com.
• Password
• Connection information; see “XMPP Account” on page 64.

System Requirements

Microsoft Internet Explorer® 6.0 or later.

Processor Minimum: Intel Pentium III 1.3 GHz or equivalent 
Optimal: Pentium 4® 2.4 GHz or equivalent

Memory 512 MB RAM 

Hard Disk Space 50 MB

Operating system Windows® Vista®
Windows 2000
Windows XP

Connection IP network connection (broadband, LAN, wireless)

Sound Card Full-duplex, 16-bit
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Multimedia Device Requirements
Bria requires both speakers and a microphone to make calls. Any of the following configurations are 
acceptable:

• External speakers and microphone
• Built-in speakers and microphone
• Dual-jack multimedia headset
• Bluetooth® multimedia headset
• USB multimedia headset
• USB phone. 

Optimized Devices
Bria is optimized to work with the following:

• Actiontec Internet Phone Wizard
• GN Netcom GN 8120 USB and GN Netcom 8110 USBXP
• Plantronics CS50-USB Wireless Office Headset System
• Polycom® Communicator C100S Wideband USB Speakerphone
• TigerJet RJ11 to USB Phone Adaptor (incorporating the Tiger560C)
• TigerJet USB Phone Set (incorporating the Tiger560C)
• Yealink USB-P1K USB hand phone

Video Cameras
Calls made with Bria will work without a video camera, but one is necessary to allow other parties to see your 
image. Bria will work with most USB video cameras.

2.2 Installing Bria
Run the Bria setup executable file and follow the prompts in the install wizard. 

If you want to configure CMC immediately, then at the final step of the wizard, select Launch Bria.
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2.3 Configuring Bria
If Bria is not already running, start it as you would any other program: Use the Windows Start menu or 
double-click the desktop icon. Bria appears.  

 Setting up Accounts
You must set up a SIP account to make phone calls. If the VoIP service provider offers instant messaging using 
SIMPLE, you will also use this account for instant messaging.

You must set up an XMPP account if you are using an XMPP service for instant messaging and presence.

1. From the Bria menu, choose File > Account Settings. The Account Settings window appears.

2. Click Add > New SIP Account. The SIP Account window appears. 

3. In the Account tab, complete the User Details area with the information obtained from the VoIP service 
provider 

4. Complete the remaining tabs as specified by the service provider or to suit your setup. Settings that you 
may need to change immediately include:

• Account tab, Domain Proxy area.
• Topology tab, if your computer is on a network and/or behind a firewall.
For more information, see “Configuring Accounts” on page 62.

5. On the Account Settings window, click Apply to register the newly added account. 

6. If you are setting up an XMPP account, click Add > New XMPP Account. The XMPP Account window 
appears. 

7. Complete the window with the information obtained from the XMPP service provider For more 
information, see “Configuring Accounts” on page 62.

8. On the Account Settings window, click Apply to register the newly added account. Press Close when the 
Status column is “Ready”. 
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Setting up for Voicemail
Your VoIP service provider may offer voicemail. If it does, then you can set up some voicemail features in Bria. 
See “SIP Account Properties – Voicemail” on page 68.

Setting up a Contact List
Typically, you will want to create contacts in order to easily make phone calls, send IMs and transfer files. You 
can set up contacts in several ways:
• During a call that you place or receive, you can add the other party to your contact list. “Handling an 

Established Call” on page 17.
• You can add addresses to the Contact list one by one. See “Adding a Contact” on page 32.
• You can import a contact list from a file or from another application. See “Importing Contacts” on page 34.
For general information on contacts, see “Contacts Tab” on page 31.

Checking for Bria Updates 
To check for updates to Bria, choose Help > Check for Updates. The Auto Update window appears.

• If a new version of the software is available, you can download it from this window.
• If no newer version is available, this window informs you that your version is up to date.
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3 Using Bria

3.1 Starting Bria
If Bria is not already running, start it as you would any other program: Use the Windows Start menu or 
double-click the desktop icon. Bria appears. 

Receiving a Presence Request
If availability is enabled, then at any time you may get a Presence Request dialog box. For information on this 
request, see “Availability” on page 39.  

     

3.2 Shutting Down
To shut down Bria, choose File > Exit. Or press Ctrl-Q.
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3.3 The Onscreen MMC 

The Bria Menu

File
• My Profile. See page 47.
• Preferences. These settings control the way that you work with Bria and apply to all accounts. See page 48.
• Account Settings.These settings control how Bria interacts with your VoIP service provider, and are set 

individually for each account. See page 62.
• Exit. To shut down Bria. You can also exit by pressing Ctrl-Q.

View
• Change the GUI. See “Showing and Hiding Parts of the MMC” on page 11.

Contacts
Lets you work with contacts. Everything in this menu except for import and export can also be performed 
directly in the Address Book panel. 

For information on these actions, including import and export, see page 31.

For information on managing blocked contacts, see “Privacy” on page 45.

Call panel. See 
page 12.

Bria menu. See below.

Phone Book panel. 
See page 31.
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Actions
Lists the actions that you can perform, depending on the current “state” of Bria. For example, if a contact is 
selected, it lists all the actions that can be performed on that contact.

Help
Provides access to various service-related features. 

Showing and Hiding Parts of the MMC

You can still receive calls when Bria is hidden or minimized. 

If you exit when Bria is minimized or in Deskbar mode; Bria will start next time as minimized or in Deskbar 
mode.

Show/hide Video panel

Show/hide Dial pad

Display as Deskbar. See page 30

Close Call panel (only Call entry field will 
remain). Click again to open

Show/hide Phone Book

Move Phone Book to a separate window

Drag to resize

Restore to large view

Close to System Tray
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3.4 Placing a Call
You can contact someone using:

• A softphone address (kpereira@domain.com)
• A traditional phone number, if supported by your VoIP service provider.

You can place a call when another call is already in progress. There is no limit to the number of calls you can 
make, although eventually the quality of audio and video will degrade because of limitations on the computer. 
We recommend no more than six concurrent calls.   

1. If you have a camera on your computer, decide how you want to handle video for this call:

• The Video panel must be open if you want to send your video immediately. When the Video panel is 
opened, the Video button appears on the Call panel.
(You always have the option of starting the call without video and then adding it later).

• The Video panel can be opened or closed if you do not want to send video. 

2. Place the call. See the table below.  

The new call is added to the Current Calls bar. You will hear a ringing tone while Bria attempts to make a 
connection.

3. Once the new call is established, switch between different calls by clicking the tab in the Current Calls bar.

Redial

Call entry field

Click a button to place the call. 
If the Video panel were open, a 
Video Call button would also 
appear here.

Current Calls bar

Call toolbar

Other calls are on hold

Filter

Open/close Video panel
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How From the ... Description

Keying Dialpad or computer 
keyboard 1. If another call is currently in progress, click   on the Call toolbar. 

A new Call Entry area appears. The current call is put on hold.
2.  Enter the softphone address or number in the Call entry field using 

the dialpad or the computer keyboard.

For the name, you can enter the entire softphone address 
(kpereira@domain.com) or just the name (kpereira).
As you type, a suggestion for completing the entry may appear. 
Choose the suggestion or keep typing.

3. To make an audio call, click the green Call button or press Enter. 
Even if the Video panel is open, an audio call will be placed.

4. Or to make a video call, open the Video panel and press Video Call.

Drag-and-drop contact or 
previous call

Contacts or History tab in the 
Address Book panel

Drag an entry from the Contacts or History tab. The call is placed 

immediately. (If the tab contains lots of contacts, first use the  field 
to filter the list.)
• If the video panel is closed, an audio call is placed.
• If the video panel is open, a video call is placed and your video wil 

lbe sent as soon as the other party answers. 

Right-click a contact or 
previous call

Contacts or History tab in the 
Address Book panel

Right-click an entry from the Contacts or History tab and choose Call or 
Video Call. The call is placed immediately. 

(If the tab contains lots of entries, first use the  field to filter the 
list.)

Double-click a contact Contacts in the Address Book 
panel

Contacts have a “double-click” action that either makes a phone call or 
starts an IM. Each contact can be configured separately for this action. 
See Table 1 on page 32.

Double-click a previous 
call

History tab in the Address 
Book panel

Double-click an entry. The call is placed.

Redial Redial button Click Options and choose Redial. Or click the Redial button. 
The call is placed immediately (without video, even if the Video panel 
is open).

From Outlook If you have set up contacts in Microsoft® Outlook®, you can place a 
call to a PSTN number (but not a softphone address). 
1. Double-click the contact in the contact list in Outlook. The Contact 

dialog box appears. 

2. Click the  in the top left corner and select the phone number to 
dial. As soon as you release, Bria will be brought to the front (or will 
be started) and the call will be placed.

You may need to revise the dial plans for your accounts in order to 
support the format used in Outlook. For example, if phone numbers in 
Outlook all have a “+9” prefix, you must ensure the dial plans for your 
accounts strip out the + correctly. For details, see “Dialing Plan” on 
page 79.
For information on how Bria and Outlook contacts work together, see 
“Exporting Contacts” on page 35.
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Placing another Call
To place a new call (without hanging up on the current call), click the Start another Call button. In the Current 
Calls bar, a tab appears for each separate call.

Hiding your Identity
You can hide your identity on a call, so that the other person will not see your ID on their phone.

On the Call control bar, choose Options > Hide my Number for this Call.  appears on the Call control bar for 
this call. Place the call in the usual way.

You identity is hidden only for this call. 

Which Account Is Used?
When placing an outgoing call, you can explicitly specify the account to use for that call. Click the Account 
Selection menu and select the desired account.

Once the call is placed, this menu always reverts back to “Auto”.

If You Do not Select an Account – Auto Account

If you have more than one account enabled and if you do not select the account, Bria selects the account to use 
to place the call as follows:

• If a dial plan exists for any account, Bria runs through the dial plans to determine if the dialed number 
matches any of these plans. If a match is found, the acount that the dial plan belongs to is used. See “Dialing 
Plan” on page 79. 

Start another Call 
button
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• If there is no match on any dial plans or if no dial plans are defined, then the default account is used. The 
default account is the account listed first in the Account Settings window (page 62).

Ending a Call
Click End on the Call panel. Details of the call remain on the Call display. To clear the details of the call from 
the display, click Clear. 
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3.5 Handling an Incoming Call
Bria must be running to answer incoming calls. (If Bria is not running, incoming calls may be directed to 
voicemail, but check with your VoIP service provider to be sure.)

Bria rings and information about the incoming call appears in the Call 
entry field. In addition, the Call Alert box appears, even if Bria is 
minimized. For information on call alerts, see “Preferences – Alerts & 
Sounds” on page 49.        

The softphone address of the person calling you is displayed. The 
display name may also appear. 

Ending a Call
Click End on the Call panel. Details of the call remain on the Call display. To clear the Call display, click Clear.

Action From the ... Description

Answer Call panel or Call Alert box Click Answer.
If you are on another call, that first call is automatically put on hold. You are 
now talking to the new caller.
Or press Enter (on the keyboard), if Bria is the active application.

Decline Call panel or Call Alert box Click Decline. There will be a busy signal. In some networks, the call will be 
directed to voicemail (if you have this service).

Permanently 
block the caller

Options menu Click the Options button and choose Block this person.

Answer with IM Options menu Click Options and choose Answer with Instant Message. The phone call is 
declined, and instead an Instant Message window appears. Type the message 
and click Send. (Or close the window if you change your mind.)
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3.6 Handling an Established Call
While the call is in progress you can:

• Control the audio: use the speakerphone, mute the call, control volume.
• Record the call.
• Put the call on hold.
• Add the caller as a contact.
• Transfer the call. See the next page.
• Add video. Pause and resume video when video is already present. See “Video” on page 20

Show/hide video panel. See page 20

Speakerphone (this button 
only appears if your 
computer has a 

Hold

Mute

Add the current 
caller as a contact. 
See “Adding a 
Contact using an 
Existing Address” 
on page 34.

Volume 

You can do any of these 
even with the call in 
progress. Many of these 
actions are also buttons on 
the Call toolbar.

Quick transfer. See page 18

Place another call (this one will automatically be 
put on hold). See page 14

Conference call. See page 22

Record on/off
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3.7 Transfering a Call

Quick Transfer
You can set up a list of phone numbers that calls can be transferred to. Then during a call, you can transfer to 
any of these numbers by selecting from a list.

To set up the numbers:

1. Choose File > Preferences from the menu. Display the Transfer panel.

2. Enter as many numbers as you want. To enter a new number, click in an empty line. To remove an entry, 
click in the line and delete the number.

Set one of the numbers as the default and click OK.

To transfer a call, click the arrow on the Transfer button and click the number to transfer to. As soon as the 
transfer is made (the other phone starts ringing), the call is disconnected at your end. 

Basic (Unattended) Transfer – Transfer this Call
You can transfer a call to any number, then hang up as soon as you have entered the number. 

1. Click Options > Transfer this Call. The LCD prompts for the number to transfer to.

2. Call the target (the person you are transfering the call to) by keying the number.

3. Click Transfer; the message Call Transfered Successfully appears.

Or click Cancel to continue the current call

Quick Transfer
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Attended Transfer – Call then Transfer
You can first speak to the target (the person you are transfering the call to), then click Transfer to complete the 
transfer.

1. Click Options > Call then Transfer. The first call is put on hold and a New call tab appears

2. Call the target in any of the normal ways.

3. When you are ready, click Transfer; the message Call Transfered Successfully appears.

If the target does not want to take the call, simply end the call with that person. The first call is taken off hold.
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3.8 Video

Adding Video

Either you or the other party can add video at any time.

To add video, open the Video panel and click Start My Video. When you add video, the other party may (or may 
not) start sending their video to you.

You can add video, even if you do not have a camera, in order to start receiving the other party’s video.

Other Party Adds Video

If the other party starts their video, the Video panel automatically opens and the video is played. You can start 
sending your own video, if desired (and assuming you have a camera) by clicking Start My Video.

Pausing and Resuming Video

If the Video panel is open and video exists in a call, the Start My Video and Stop My Video buttons appear, to 
let you pause and resume video.

If you close the Video panel, your video will stop being sent; you can reopen the panel and click Start My Video 
again.

Show/hide video 
panel
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3.9 Voicemail
If your service includes voicemail, then when you have voicemail messages, the word “new” appears beside the 
voicemail icon at the top of the phone. Click the icon to automatically connect to voicemail and listen to your 
messages.

3.10 Forwarding Calls
Forwarding Calls
You can enable or disable forwarding so that calls will be forwarded to another number. You can set up 
forwarding so that calls are always forwarded or so that calls are forwarded only when you are on another call.

To enable forwarding, choose File > SIP Account Settings. Select an account and click Edit, then click the 
Voicemail tab. For complete details, see “SIP Account Properties – Voicemail” on page 68.

Control video from the Call 
panel or the Video panel

This button only appears 
when video 

Voicemail icon
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3.11 Conference Calls

Starting a Conference Call
You can create a conference call starting from one existing call:

1. Click the Conference icon. Bria enters “conference mode” and “Call a conference participant” appears on 
the LCD.

2. Place the second call in one of these ways:

• Right-click on a contact and choose Add to Conference Call.
• Type a name or number. 
(Or to cancel the call, click the Cancel button.)

When the second callee answers, the call will automatically be added to the conference.

Or you can start a conference call using all the existing, separate calls:

1. Establish the calls. The calls can be incoming or outgoing, and one or more calls can include video.

2. Click Conference All. 

Conference icon Enter phone number for new participant
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Managing the Conference

Adding More Participants
You can add more participants to an existing conference in any of these ways:

• Right-click on a contact and choose Add to Conference Call.
• From the tab that contains the conference, click the Conference icon. Place a call by typing a name or 

number. When the callee answers, the call will automatically be added to the conference.
• Place a separate outgoing call in the normal way (by clicking the New Call icon to display a new tab). 

When the call is established, click Conference All. All existing separate calls will be brought into the 
existing conference.

• Accept one or more incoming calls. A separate call will be established for each call. Click Conference All. 
All existing separate calls will be brought into the existing conference. 
Whenever you click Conference All, all current established calls are conferenced together; you cannot keep 
any one call out of the conference.

Removing a Participant
To remove one call from the conference, right-click on that participant and choose Separate Call from 
Conference. The call becomes a separate call.

Disbanding the Conference
To break the conference into separate calls, click Options > Disband Conference.

To hang up on everyone, click the End button.

Suspending the Conference
To suspend the conference, click the Hold button. 

Conference is now established
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Audio Controls
Adjusting Volume. Use the speaker adjustment to adjust volume of the sound you are hearing. 

Mute. Click  on the dialpad to prevent the other parties from hearing you. The  icon appears on the Call 
display. When you mute, you may also want to stop video feed, if any.

Speakerphone. Click  on the dial pad to put the callers on the speaker phone. The  icon appears on the 
Call display.

Video Conference Calls

Starting a Conference with Video
To start a conference with video, make sure that both the existing calls are video calls. Then click the 
Conference button.

Adding Video to an Existing Conference Call
Choose Options > Start Group Video. Your video starts immediately.

Or open the Video panel and click Start my Video. 

When you add video, the other party may (or may not) start sending their video to you. You can add video, even 
if you do not have a camera, in order to start receiving the other party’s video.

How Video Is Shared
When you conference two calls together, video continues as it was before the conference call. For example, if 
you were sharing video with one party, and only sending your video to another party, then that is how the video 
will be handled when the conference call is created. 

The conference host, serves as the “funnel” for other video. Whatever the conference host is receiving will 
automatically be sent to the other parties. 
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Controlling Video
Once video has been added, it can be paused, resumed and stopped in the same way as on a regular conference 
call, by the intitiator of the individual “leg” of the conference call.

The conference host does not have special control over the video, and can only add video on legs for which they 
were the initiator.

However, if the conference host pauses or stops video, other participants will no longer receive video, because 
the host is the video “funnel” as described above.
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3.12 Instant Messaging
Instant messages are made using softphone address. Therefore, you can send or receive an instant message (IM) 
to:

• Any contact who has a softphone address.
• Any party who phoned you from a softphone address.
• Any party whom you phoned using a softphone address.

Sending an IM
1. There are several ways to select the person to send an IM to.

The Instant Message window appears. Or if another Instant Message session exists, a new tab is created for 
this IM session. 

2. Type the message. Include emoticons and formatting, as desired. 

To insert a return in the message, press Ctrl-Enter. (You can control the behavior of Enter and of Ctrl-Enter; 
see “Preferences – Application” on page 48.)

3. Press Send or Enter.

You can press Ctrl-F to search for text in the large message area.

From the Contacts tab in the 
Address Book

Right-click on the contact and choose Send Instant Message. The contact must 
have a softphone address.

An active phone call The person in the active phone call. Choose Options > Send Instant Message.

A person on hold In the Current Calls bar, click the arrow next to this call and choose Options > 
Send Instant Message.

From the History tab in the 
Address Book

Right-click on the entry and choose Send Instant Message. 

A separate tab for each IM conversation. 
The active conversation appears in bold.
If a message comes in on a hidden tab, the tab flashes.
Click the button to close one conversation.

Click to perform one of these actions 
for the active conversation.

Message input area
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Receiving an IM
When an IM is received, either the IM window or a Call Alert pops up. (To control which window appears, see 
see “Preferences – Application” on page 48.)

If the IM window is already displayed with an IM session with another person, the message from the new 
person appears in another tab in that window. (You can set up Bria so that each person has their own IM 
window; see “Preferences – Application” on page 48.) 

Sending a Broadcast IM
You can send an IM to several people at one time. A broadcast IM is not a conference IM. 

• With a broadcast IM, each recipient can reply to the IM, but only you will see these replies; the other 
recipients will not see these replies. 

• With a conference IM, all parties see everyone’s messages and the messages each party sends are seen by 
everyone. Conference IM is currently not supported.

1. Select the parties from the Contacts tab in one or more of the following ways:

• Select one or more contacts in the usual ways (using Shift-click or Ctrl-click).
• Select one or more groups in the usual way.

2. Right-click and choose Send Broadcast Instant Message. The Send Instant Message to Group window 
appears.

3. Type the message. Include emoticons and formatting, as desired. 

To insert a return in the message, press Ctrl-Enter. (You can control the behavior of Enter and of Ctrl-Enter; 
see “Preferences – Application” on page 48.)

4. Press Send or Enter. The IM is sent and the window closes.

A recipient may send you a response, which will be displayed to you in a regular Instant Message window; 
you will then be in a regular IM with that one party.

You can press Ctrl-F to search for text in the large message area.

Shows the display names of all the selected contacts and 
the individual display names of all the contacts in any 
selected groups. Contacts that do not have a softphone 
address are not included in the list.
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3.13 Sending and Receiving Files

Sending Files
If you have an XMPP account, you can send files to any contact who also has an XMPP account.

1. From the Contacts tab, right-click a contact and choose Send Files. (If the contact does not have an XMPP 
address, then this menu does not appear).

Or from an existing IM window, choose Send a File. (If the contact does not have an XMPP address or if 
you are not using the contact’s XMPP address for this IM session, then this menu does not appear).

 

2. A standard Select Files to Send dialog box opens. Select the files to send and press Open. The Send Files 
dialog appears, with a “waiting” message. If you want, you can cancel the send before the other person 
retrieves them.
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Receiving Files
If you have an XMPP account, another person with an XMPP address may send you files. The following dialog 
appears, to allow you to save the file.
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3.14 Email
You can send an email to one or more contacts, or to all the contacts in a group.

Select the contact, contacts or group, right-click and choose Send Email. An email window opens in your 
default email application, with the “to” line populated with all those contacts who have email addresses (in their 
Contact Profiles).

3.15 The Deskbar
The Deskbar provides a compact GUI for performing many Bria actions. It is assumed that you will work in this 
mode after you are quite familiar with Bria and its features.

 

Your availability Switches between Call 
button and End button

Menu changes depending on whether 
there is an entry in the entry fieldEntry field

Restore to main window

Missed calls
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4 The Address Book

The Address Book panel, which is divided into tabs, provides access to the following: 

• Contacts.
• Call history, see page 38.
• Contact availability (presence), see page 39.

4.1 Contacts Tab

The Contacts tab displays your contacts and lets you specify multiple contact methods for them, including:

• Softphone address 
• Home phone number, business phone number, cellphone number
• Fax number (this is provided for convenience; Bria does not have any fax capability).
• Email

You can identify one of these contacts as the primary contact method. 

Contacts are typically organized into groups. Bria includes built-in groups: “Friends”, “Home” and “Work”. 
You can add more groups, as desired.

Add a Contact

The availability of others. See page 39.

Display all contacts

Search field

Display only contacts who are set up for 
Availability and who are currently online
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Setting up Contacts

Adding a Contact

Click , or right-click a group and choose Add Contact to Group. The Contact Profile dialog box appears. 
See the table on page 36.

Table 1: Contact Profile Fields

Field Description

Contact name Only the display name is required. This is the name that will appear in the Call display and the 
Call Alert when this person phones you.

Group Either:
• Choose one group.
• Click More and select several groups. The new contact will be added to each group.

Ring tone Choose a ring tone for this contact, or use the preferred sound (which is defined in Preferences > 
Alerts). Click the arrow to play the currently selected ring tone.

Contact Methods Enter as many contact methods as you want. Email and softphone entries must have the format 
<name>@<domain>

Advanced The Advanced dialog appears, showing all the addresses for the contact. See below.

Double-click action Choose the desired method. This method will be used when you double-click this contact. 
For example, if you choose “IM:kpereira@domainA.com”, then double-clicking this contact will 
open an IM window using this address (rather than any of the other addresses that exist for this 
contact).

Other fields Complete as desired.

This button is always displayedfor 
a new contact. It also appears 
once you enter a new address for 
an existing contact.
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Contact Profile — Advanced Dialog
This dialog lets you fine tune the presence sharing information for this contact and change the account that each 
address is associated with.

Presence Sharing

You can configure which accounts will be used for presence sharing: none, some or all. 

• If you disable all items, this contact will not have an availability icon beside its name in the Contact list.
• If you enable at least one item, the availability icon will be gray; later its color will change to indicate the 

current availability. 

Associated Account

You can change the account that an address is associated with. 

The associated account will be used for sending IMs, for sharing presence information, and for file transfers 
(XMPP accounts only). This means that the associated account must be enabled in order to use the address for 
IM, presence sharing and file transfers.

The associated account will not be used for placing phone calls; phone calls select the account using a different 
rule; see “Which Account Is Used?” on page 14.

The associated account must be an enabled account of the correct protocol (a SIP account for an address in a 
softphone slot, an XMPP account for an address in a Jabber slot). Bria makes the initial association by trying to 
match the domains. If that fails, it will select the first enabled account of the appropriate protocol. If no 
appropriate account is enabled, the association will not be made (the Account will show as “Unavailable”).
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Adding a Contact using an Existing Address
You can add a contact by capturing existing information:

• If you are on a phone call with a person who is not a contact, click the Add to Contacts in the call panel.
• If you are in an instant message session with a person who is not a contact, click the Add button.
• On the History tab, select an entry that is not a contact. Right-click and choose Add as Contact.

The Add a Contact dialog appears. 

If the user portion of the address matches the user portion of an existing address, the Update option is 
automatically selected. For example, if the address is kpereira@domainB.com and there is an existing contact 
an address of kpereira@domainA.com. Otherwise, the Create option is automatically selected.

Take the appropriate action:

• Create a new contact: Click Create. Change the display name, contact method, and group if desired. Press 
OK.

• Update an existing contact. Click Update. Choose a different contact, if necessary. Change the contact 
method and group, if desired. Press OK.

If the contact method is Softphone or Jabber, an online status request is sent to this person.

Importing Contacts
You can populate the Bria contact list by importing from an external file. The new contacts will be added to the 
existing contacts. 

You can import a contact list from:

• A comma-separated file. Use this method to import from a Microsoft® Excel® file. You will first have to 
set up the file; see below. 

• A Microsoft® Outlook® or Microsoft® Exchange contact list (a *.pst file).
• A vCard file (*.vcf file). A vCard is an electronic business card that is often attached to an email.

1. From the main menu, click the Contacts menu and choose Import Contacts. The Import Contacts wizard 
starts. 



CMC Bria 2.2 for Windows User Guide

35

2. As soon as you click Finish on the wizard, the Contacts tab in Bria is updated to show the imported entries. 
Note that none of the entries are set up with availability turned on; in order to view availability of contacts, 
you must modify the appropriate entries by changing the Show this contact’s Availability checkbox. See 
above for details.

Setting up an Excel File for Import

1. Remove any introductory text or headings from the top of the file. (You can keep text at the end of the file; 
it will be ignored during the import.)

2. Insert a blank row as the first row, then insert the headings that Bria will use to interpret the meaning of 
each column. The columns can be in any order. The most popular headings are:

• display-name
• entry_id
• given_name
• surname
• postal_address.
For a complete list of headings, see “Contact List Headings” on page 85.

3. Save the file as *.csv.

External Storage of the Contact List
Each time Bria is started, the contact list is retrieved from the external storage. Each time a contact is added to 
the contact list, it is immediately copied to external storage. 

The list is always stored on the local computer. In addition, if you have access to a remote storage server, you 
can configure Bria so that the contact list is also stored remotely using XCap or WebDAV. 

To set up for remote storage, see “SIP Account Properties – Storage” on page 73.

Exporting Contacts
You can export a contact list to a comma-separated file, a pst file or a vcf file.

1. From the main menu, click the Contacts menu and choose Export Contacts. The Export Contacts wizard 
starts. 

2. When you click Next, the export starts. The result is:

• For an Outlook export, the existing.pst file is updated to include the entries from the Bria contact list. If 
Outlook is open, the entries immediately appear in the contact list. 
All information in the Bria contact list is exported to Microsoft Outlook. Only information that can be 
displayed in Outlook actually appears in the Outlook Contacts window. Typically this means that all 
softphone addresss are exported (and stored in custom fields) but not displayed in Outlook.

• For other formats, a new file of the specified type is created.
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Managing Contacts

Changing Contact Information
To change the information for a contact, right-click the contact and choose View Profile. The Contact Profile 
dialog box appears, see page 32. Some of the changes you can make are:

• Change any contact details.
• Add, delete or change a contact method.
• Move a contact to another group by selecting a different group.
• Add an existing contact to more groups by selecting one or more extra groups.
• Change the Show this contact’s availability checkbox to enable or disable availability information for this 

contact. For information on availability, see page 39.

Moving or Deleting a Contact
• To drag one or more contacts to a different group, select them and drag to the new group.
• To delete one or more contacts, select them, right-click, and choose Delete. The contacts are removed from 

this group. 

Adding, Deleting or Renaming Groups
Select any group, right-click, and choose the appropriate menu item.

You can only delete an empty group. 

Using Contacts
Phone or IM the person • Double-click the contact to start a phone call or IM to the person 

(depending on how double-clicking is configured in the contact’s 
profile).

• Drag the contact to the Call display to start a phone call.

Phone the person Right-click and choose Call, then click the desired number.

Send an IM Right-click and choose Instant Message.

Call a contact and include video Right-click the contact and choose Call with Video. The Video panel opens, 
and the call is placed. As soon as the other party answers, Bria starts sending 
your video.

Email a contact who has an 
email address

Right-click and choose Send Email.

You can watch the contact’s 
availability, if the contact has a 
softphone address

See Table 2 on page 43 for the meaning of the availability icons. 

See “Availability” on page 39 for information on obtaining availability 
information.



CMC Bria 2.2 for Windows User Guide

37

Contact Flyout
Left-click on a contact to show the Contact flyout. This flyout shows all the contact methods set up for the 
contact and has icons you can click to perform an action that is valid for that contact method.

Finding a Contact

If the contact list is long, use the  field to filter the contacts that are displayed. To clear the filter and 

redisplay all contacts, clear the  field.

Click an icon to perform the action. 
This contact is online on their 
domainA account but offline on 
their domainXMPP account



CounterPath Solutions, Inc.

38

4.2 History Tab

Managing the Lists of Calls
You can right-click on an entry in a list to:

• Delete the call.
• Delete all entries in this list.
• Block this person to control whether they can send you phone calls or instant messages, or see your online 

availability. You can change these privacy settings at any time; see page 50.
• Add to contacts. The Add a Contact dialog box appears. Complete the dialog box and press OK. For more 

information on the fields, see “Adding a Contact using an Existing Address” on page 34.

Phoning and Sending IM from a List
You can right-click on an entry in the Received or Dialed list to:

• Place a call to this person, using the contact method that was used for this call. You can also double-click to 
place a call.

• Place a call to this person and add them to a conference call that is in progress. For more information on 
conference calls, see “Conference Calls” on page 22.

• Send an instant message, if the call was made with a softphone address. For details, see page 26. 

Display all calls

Dialed calls

Missed calls

Received calls

Missed or blocked 
incoming

Answered call (incoming 
or outgoing)

Canceled outgoing
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4.3 Availability
Availability refers to the ability to see whether a person is available or not: online, on phone, busy, and so on. 
Your availability information is displayed below on the main menu. The availability of others is displayed in the 
Contacts tab. 

You can publish your availability to contacts who have softphone addresss, and you can set up Bria to view the 
availability of other contacts.   

If the contact has several addresses, you can look at their profile for information on which addresses are 
currently online:

Your availability

Availability of other people

This person may be 
logged out

This contact is currently online on their 
domainA account. This account supports 
phone and IM.

The contact is not online on their 
domainXMPP account. This account 
supports IM but not phone.
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Sharing Availability

Watching others’ Availability 
To be able to see the availability of another person, either add that person to Contacts with the “Show this 
contact’s availability” field checked, or modify the existing contact information so that this field is checked. For 
more information, see page 36.

As soon as the person is set up in this way in your Contacts, Bria sends them a notification request. The request 
asks that you be able to see that person’s availability. If the person allows this request, then the icon beside their 
name (in your Contacts) becomes color coded, so you can determine their availability. 

Allowing Other Parties to See your Availability (Publishing your Availability)
Continuing from above, when the other person allows the notification request, your name is added to their 
contact list. As soon as you are added to their list, a request is sent back to you requesting that they be able to 
see you. You can reply to this request to complete the sharing loop.

Troubleshooting: When You Cannot See Availability
If you have multiple accounts set up, icons may remain gray when you expect them to be color coded. For 
information on how this can happen, see “SIP Account Properties – Presence” on page 72.

The following chart illustrates how the sharing of availability occurs.

Joseph Kokila

Joseph adds Kokila to his contact 
list with “Show this contact’s 
Availability” checked

Joseph’s eyeBeam sends a “let me see you”
 notification request to Kokila

Kokila receives a notification 
request and responds by clicking 
“Allow and add”

Now that Joseph is in Kokila’s contact list, Kokila’s 
eyeBeam sends “Let me see you” notification request to Joseph

Joseph receives a notification 
request and responds 
“Allow” Response sent

Availability icon is added 
for Kokila, colored gray

“Allow” response sent

Joseph’s availability icon 
turns green

Privacy rule is created for 
Joseph with “allow” and “show”

Joseph is added to Kokila’s 
contact list

Availability icon is added 
for Joseph, colored gray

Kokila’s availability icon 
turns green
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Receiving a Presence Request
Your Bria receives a new contact request when you add a contact to your list (with “Show this contact’s 
Availability” checked) or when another person adds you as a contact at their end.

The request is handled in one of two ways:

• If you set up a privacy rule before this person has a chance to contact you, then you will never see this 
request. Bria will automatically reply to the request according to the rule. See “Preferences – Privacy” on 
page 50.

• If you do not yet have a privacy rule set up for this person or for their domain, this request appears to you as 
a Presence Request. You must respond to the request:
• Block the request. This person will not be able to contact you from this address.
• Allow the request and create a new contact using this address.
• Allow the request and add this address to an existing contact (if Bria has found an appropriate match).
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For important information on how privacy affects availability, see “Privacy” on page 45.

Button Next Action Result

Allow and Add to 
Contacts

This button appears only if the other person is 
not already on your contact list. 
When you click this button, the Add a Contact 
dialog box appears. Complete the dialog box 
and press OK. For more information on the 
fields, see “Managing Contacts” on page 36. 

The other person will:
• Be able to see your availability. 
• Be added to your Contacts. 

In the future, you will not receive this request from this 
person.
In addition, this same request will be sent to the other person, 
so that you can see their availability. 

Allow The other person will:
• Be able to see your availability, but for this session only. 

Because you have not set up the person as a contact, a 
Presence Request will appear for this person each time you 
start Bria. 

Block The other person will:
• Not be able to see your availability. 
• Not be able to phone or IM you.
• Be added to your Blocked List. See “Preferences – 

Privacy” on page 50.

Close the window The other person will not be able to see your availability. The 
other person will not be added to your privacy settings.
The Presence Request may appear again in this session or a 
future session
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Setting your Availability

Changing your Availability
Click the down arrow beside the availability indicator on Bria, and select the desired availability. See Table 2, 
below.

When your availability changes, the new availability is sent to everyone who has permission to see your 
availability, according to the Privacy Settings (see “Preferences – Privacy” on page 50).

Setting up Availability Indicators
You can create custom availability indicators, or edit or delete custom or built-in indicators: click the down 
arrow beside the availability indicator, and choose Custom Message.
 

Table 2: Availability Indicators

Indicator Meaning for your Availability Meaning for Others’ Availability

Available Either:
• You have set your availability to this status. 
• Bria has determined that you are logged on but not on the 

phone or idle.

When you have this availability, Bria will automatically detect 
when you are idle or on the phone, and change the availability to 
match.

You can contact this person.

Busy You have set your availability to this status. Bria will never 
automatically switch you out of this status; you must switch 
yourself.

You can contact this person.

On the phone Either:
• You have set your availability to this status. In this case, Bria 

will never automatically switch you out of this status; you 
must switch yourself.

• Bria has detected that you are on a call. When your call 
finishes, your availability reverts to the last availability.

You can contact this person.

Not Available 
for calls

You have set your availability to this status. Bria will never 
automatically switch you out of this status; you must switch 
yourself.
Incoming phone calls will be directed to voicemail.

Your phone calls to this person will be 
directed to voicemail. 
You can IM this person.



CounterPath Solutions, Inc.

44

Do not disturb You have set your availability to this status. Bria will never 
automatically switch you out of this status; you must switch 
yourself.
Both incoming phone calls and incoming IMs will be directed to 
voicemail.
However, you can still make phone calls and IMs. When the 
other person responds, your availability will remain as Do not 
disturb. 

You cannot make phone calls or IMs to this 
person.

Idle You have not moved or clicked the mouse or pressed a keyboard 
key for the Idle period. To set the Idle period see “Preferences – 
Application” on page 48.
As soon as you click the mouse or keyboard, your status changes 
to Available.

You can contact this person.

Away You have set your availability to this status. Bria will never 
automatically switch you out of this status; you must switch 
yourself.

You can contact this person.

Offline Not applicable The contact is either not logged on or else is 
not set up for availability. 

Table 2: Availability Indicators

Indicator Meaning for your Availability Meaning for Others’ Availability
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4.4 Privacy
You can control how contacts and other people can contact you by phone or IM, and you can control whether 
your contacts can see your availability information (whether you are online, one the phone, and so on).

You can set up controls in advance or “on the fly” (as phone calls and presence requests come in)

Setting up Controls in Advance
To set up controls in advance, see “Preferences – Privacy” on page 50.

Setting up Controls “on the Fly”

On an Incoming Call
To block someone when they are phoning you, choose Options > Block this Person. 

The call is declined, and this person is added to your Blocked List (see page 50). In addition, if the person is a 
contact, then “blocked” appears beside their name in the contact list. 

You will no longer see incoming calls or instant messages from this person; they will automatically be declined. 

To later unblock this person, remove them from your Blocked List. Or, if the person is a contact, right-click 
their name on the contact list and choose Unblock this Person.
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On an Incoming IM
To block who sends an IM, choose Options > Block this Person on the Instant Message window. Then close the 
window. 

The other person gets a message that their instant message has been declined.

This person is added to your Blocked List (see page 50). In addition, if the person is a contact, then “blocked” 
appears beside their name in the contact list. 

You will no longer see incoming calls or instant messages from this person; they will automatically be declined. 

To later unblock this person, remove them from your Blocked List. Or, if the person is a contact, right-click 
their name on the contact list and choose Unblock this Person.

Via the Presence Request Dialog Box
Another party can send you a presence request, to request that they be able to see your availability, as described 
on page 39.

Your response has the following effect on privacy:

• If you add the person as a contact, then the ability of that person to phone or IM you is controlled by your 
privacy settings; see “Preferences – Privacy” on page 50.

• If you allow the person without adding them as a contact, then the ability of that person to phone or IM you 
is controlled by your privacy settings; see “Preferences – Privacy” on page 50.

• If you block the person, then that person is added to your Blocked List (see page 50). The person will not be 
able to phone or IM you, and will not see your availability information. You can change this blocking by 
removing the person from the Blocked List, in which case they will then be controlled by your privacy 
settings.

From the Contact List or History List
Right-click on the name and choose Block this Person. The person will be added to your Blocked List (see 
page 50). The person will not be able to phone or IM you, and will not see your availability information. 

To later unblock this person, right-click on the name and choose Unblock this Person.
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5 Configuring Bria

You can configure Bria in several ways:

• Set up your personal profile. See below.
• Configure global behavior. See “Configuring Preferences” on page 48.
• Configure the behavior on a per-account basis. See “Configuring Accounts” on page 62.

5.1 Configuring your Profile

To set up information about yourself, choose File > My Profile. In later versions of Bria, you will be able to 
share this information with other users. 
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5.2 Configuring Preferences
Choose File > Preferences. The Preferences window appears. 

The Preferences panels let you control the way that you work with Bria. 

Preferences – Application

This panel lets you set your preferences for general GUI behavior. 
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Preferences – Alerts & Sounds

This panel lets you control the Call Alerts box and lets you assign sounds. 

Showing Call Alert Box

You can control whether the Call Alert box is displayed in different 
situations.    

   

Assigning Sounds

You can assign specific sounds to a variety of actions or “events”. 

1. Click Enable sounds on and click each event on or off, or click Enable sounds off to disable all sounds.

2. If enabling sounds, you can change the sound for each event: select the individual event. The value in 
Sound preference will change. Select the desired sound.

Keep in mind that you can also override any sound for an individual Contact; see page 32. 

You can import sounds; these will be added to the list of sounds you can choose from when assigning a sound to 
an action.
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Preferences – Privacy
You can control how contacts and other people can contact you by phone or IM, and you can control whether 
your contacts can see your availability information (whether you are online, on the phone, and so on).

Choose one.
If you choose “Allow only”, then all 
contacts will be able to contact you 
unless they or their domain  are in 
the Blocked list (below).

This section is optional. It lets you 
enter addresses and domains that 
will be prevented contacting you.
You can add and remove entries 
from the blocked lists.
In addition, entries are automatically 
added to this list when you block 
someone “on the fly” (page 45).

If you enter a domain in this list, 
people in that domain will 
automatically be allowed to see your 
availability online.
You will no longer see Presence 
Request dialogs from these people in 
this domain. 
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Preferences – Quick Transfer

This panel lets you set up a list of phone numbers that calls can be transferred to. Then during a call, you can 
transfer to any of these numbers by selecting from a list.

Enter as many numbers as you want. To enter a new number, click in an empty line. To remove an entry, click in 
the line and delete the number. Set one of the numbers as the default.

See “Quick Transfer” on page 18 for information on using this feature.
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Preferences – Devices

Bria automatically detects devices at each startup, and selects the most appropriate device for each purpose. If 
you do not like this selection, you can override it on this panel.

If you override a selection, it will be honored the next time you start Bria, unless the device is no longer 
available, in which case Bria will again select the device to use.
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Field Description

Headset Mode

Speaker 
Microphone 

Change these fields only if you want to override the devices that Bria 
automatically selected.
In both these fields, select the headset you are using.
The headset is the device that is usually used for audio out (the sound you hear) 
and audio in (recording your voice). The only situation in which the headset is 
not used is when the Speaker Phone button on the dialpad is pressed. 
Therefore, unless you will always be using Bria in speakerphone mode, you 
must make a selection here.
Select the headset in both the Speaker device field and Microphone device field.

Speakerphone Mode

Speaker Change this field only if you want to override the devices that Bria 
automatically selected.
Make the appropriate choice:
• Select the device that you want to use for audio out (the sound you hear) 

when the Speaker Phone button is pressed. Make sure you select a speaker 
device (not the headset).

• Select None if you do not have a speaker phone. The Speaker Phone button 
on the dialpad is disabled.

Microphone Change this field only if you want to override the devices that Bria 
automatically selected.
Make the appropriate choice:
• Select the device that you want to use for audio in (recording your voice) 

when the Speaker Phone button is pressed. 

It can be any microphone: it does not have to be the microphone on the 
device you specified as the speaker device. For example, it can be the 
microphone on your camera. 

• Select None if you do not have a speaker phone. The Speaker Phone button 
on the dialpad is disabled.

Reduce background noise Automatically attempts to remove background noise.
Typically on for the speakerphone.

Phone Ring Device

Ring Device Change this field only if you want to override the devices that Bria 
automatically selected.
The device where you want to hear the phone ringing: the headset, the 
speakerphone, or none.

Ring volume The volume of the ringer.

Also ring PC speaker Click on or off, to suit your preference.

Camera

Camera Change this field only if you want to override the devices that Bria 
automatically selected.
Select the camera model.
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Preferences – Network

Field Description

Network Connection Speed Select the type of network connection for your computer.
The sliders move to show the bitrate that will be used for sending and receiving. 
These rates are typical rates for the selected configuration.
If you know that your computer and network can handle a faster sending speed, 
click Custom and move the slider.
It is recommended that you not change the receiving speed.
• You will know that you have set the sending speed too high if:

The remote video shows black areas or is slow or jerky.
The remote audio is garbled.

• You will know that you have set the sending speed too low if the audio is 
good but the video is of poor quality (grainy).

Video Image Size Leave at standard, or change the size as follows:
• Set it to high if if hae a good camera and a computer with lots of CPU. You 

will know that you have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using wifi 
in a hotel. You will know that you have set the size too small if the video is 
fuzzy.

Preserve bandwidth When this feature is on, Bria stops sending audio when you are not talking.
When this feature is off, Bria always sends audio, which uses more bandwidth 
but may result in better call quality.
Typically off. However, if you are using a slow (dial-up or ISDN) connection, 
you may want to turn it on. 
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Preferences – Audio Codecs

This panel shows all the codecs that are included in the retail version of Bria. You can enable or disable codecs 
as desired.  

With only one codec enabled, all calls made will use that codec. With more than one codec enabled, Bria 
automatically chooses the best codec based on the other party’s capability, the available bandwidth, and 
network conditions.

You cannot change the properties of any codecs.

About Codecs
Audio codecs describe the format by which audio streams are compressed for transmission over networks. 
Codecs can be categorized as either narrowband or wideband:

• Narrowband codecs work with low bandwidth such as a dialup internet connection. These codecs have a 
sampling rate of 8 KHz.

• Wideband codecs work with high bandwidths and result in better audio quality. However, they do not work 
with PSTN. These codecs have a sampling rate of 16 KHz.
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Supported Codecs
Bria supports a wide range of codecs. See the table.

Codec Narrowband Wideband Royalty-bearing Included in 
Retail Bria

AMR Wideband (G.722.2)

Broadvoice-32

Broadvoice-32 FEC

DVI4

DVI4 Wideband

EVRC

G.711aLaw *

G.711uLaw *

G.722

G.723

G.726

G.729 *

GSM

iLBC

L16 PCM Wideband

Speex

Speex FEC

Speex Wideband

Speex Wideband FEC

* Generally, at least one of these codecs must be enabled in order to place a PSTN (land line) call. 
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Preferences – Video Codecs

This panel appears only on versions of Bria that include video functionality.

Video codecs describe the format by which video streams are compressed for transmission over networks.  
Some codecs require less bandwidth than others, but may result in lower video quality.

You can enable or disable codecs as desired. You may decide to disable a codec even though your VoIP service 
provider supports it. 

With only one codec enabled, all calls made will use that particular compression format. With more than one 
codec enabled, Bria automatically chooses the best codec based on the other party’s capability, the available 
bandwidth, and network conditions. 

You cannot change the properties of any codecs.

Supported Codecs
   

Codec Royalty-bearing Included in 
Retail Bria

H.263

H.263+ 1998

H.264 (low end)

H.264 (high end)
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Preferences – Quality of Service

The Quality of Service panel lets you request a specific transport service for audio, video and signaling traffic.

There are two types of services. The service to use depends on what your internet service provider supports:

• GQoS, which is available for audio and video.
• DSCP (also known as ToS), which is available for audio, video and signaling.

In a network that has the default configuration, the recommended value for audio is 46, because “46” is the 
standard marking for audio.

Bria supports 802.1p QoS packet tagging. If you set up for QoS, Bria will include the specified information in 
the packets that it sends to the network provider. Whether the packet is delivered with the specified service 
depends on whether your broadband router and the network provider between you and the other party supports 
multiple transport services. In other words, whether each network provider reads the QoS information and 
prioritizes packet delivery based on the requested service. 

These fields appear only on versions 
of Bria that include video.
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Preferences – Contact Storage

These settings let you set up a remote storage system for your contact list via WebDAV or XCAP. (The contact 
list is always stored locally, even when you set up for remote storage.) 
The contact list holds general information for contacts. It is automatically loaded at startup, and is loaded even 
if no accounts are enabled.

Table 3: SIP Account Properties – Storage

Field Description
Storage method The storage method to be used for the Contact list file. The file can be stored 

locally or both locally and on a remote computer.

Server Settings
Use SIP credentials Check this box to use the username and password from your SIP account in order 

to log into the storage server.
Otherwise, uncheck this box and complete the Username and Password fields.
Not used for “Local”.

Root URL URL of an appropriate root folder on the remote server.
Not used for “Local”. The factory setting is https://webdav.$domain$/webdav/
$username$/

WebDAV poll time Enabled only for WebDAV. The time that elapses between polling for new 
contact data from the remote server.
The factory setting is 600.
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Preferences – Diagnostics

This panel lets you enable logging to files. Logging uses computer resources, so you should only enable it when 
instructed by a customer support representative.

To set up logging:

1. Click Enable diagnostic logging. 

2. Set the logging level. 

3. Specify the folder where logs will be saved.

4. Click OK.

Activity on Bria will be logged to.csv files in the specified folder. A new set of files is started each time you log 
on. In order not to create large files when logging (which may create computer problems), you must not remain 
logged on indefinitely when logging. You should occasionally exit and restart Bria.

If requested by a customer support representative, you can:

• Open the logging folder and then open a log file using a text editor. 
• Email the logs in the specified folder to customer support: Click Send logs to customer support. A dialog 

box appears showing all the logs. Select files and click Open; the selected files are sent and the dialog box 
closes.

You can delete log files from the specified folder as you would delete any file on your computer.
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Preferences – Advanced

Field Description

Reduce echos Turning this feature on improves sound quality. This feature is typically on.

Use slower but more compatible video format Turning this field on may improve performance when runing Bria on older 
hardware.
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5.3 Configuring Accounts
Choose File > Account Settings.The Account Settings window appears. 

Accounts Settings Window
To work with accounts, choose File > Account Settings from the menu. The Account Settings window appears, 
showing all the accounts set up. 

You can:

• Add or remove an account. 
• Enable one or more accounts. See below for details.
• Set one account as the default. See below for details.
• Set or change the properties of an account. These properties control how Bria interacts with your VoIP 

service provider, and are set individually for each account. Click the Properties button, then see the 
following pages for details. 

Enabling Accounts
You must enable an account in order to make and receive calls on that account. You can enable as many 
accounts as you want. Click the Enable box beside each account. The rules for enabled accounts are:

• When multiple accounts are enabled, you will be able to receive calls on all those accounts.
• You can never place a call on a disabled account. If you place a call that is only valid on the disabled 

account, it will fail with a “Not found” message.
• You can never receive a call on a disabled account. If another party phones you on a number that is only 

known to a disabled account, the call will never appear on your MMC. 
• When multiple accounts are enabled, the account to use for an outgoing call is determined by the rules of 

the dial plan determine which account is used. See “Dialing Plan” on page 79. If you have not set up any 
dial plans, then the default account is used. 
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Setting the Default Account
When multiple SIP accounts are enabled, the first account listed is always the default. Use the Move Up and 
Move Down buttons to set the desired account as the default. 

The dial plan rules may select the default SIP account in order to place an outgoing call, as described on “Which 
Account Is Used?” on page 14.
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XMPP Account

Table 4: XMPP Account Properties – Account

Field Description
Account name If desired, change the account name to something that is meaningful to you. For 

example, the name of the VoIP service provider.
Protocol Read-only. Always specifies XMPP.

User Details
Jabber ID Typically the account number for the softphone account plus the domain. For 

example, kpereira@domainXMPP.com. Provided by the XMPP service provider.
Password Provided by the XMPP service provider.
Display name This name is displayed in the Bria display.

Other parties will see this name they are when connnected to you.

Domain Proxy
Port selection Configures the port to use. 

If you choose “User selected”, complete the Connect port field. 
Connect port Complete only if Port selection is set to “User selected”
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Outbound proxy The value in Jabber ID and in this setting may be used by Bria to compose a 
valid jid:
• If Jabber ID=bob@ABC.com and Outbound proxy is empty, jid=Jabber ID: 

bob@ABC.com
• If Jabber ID=bob@ABC.com/home and Outbound proxy is empty, jid=Jabber 

ID: bob@ABC.com . .
• If Jabber ID=bob@ABC.com and Outbound proxy=XYZ.com, ignore the 

Outbound proxy; Jabber ID=bob@ABC.com
• If Jabber ID=bob@ABC.com and Outbound proxy=IP address or host 

address, jid=Jabber ID. (IP address is used as the outbound proxy).
• If JabberID=bob and Outbound proxy=ABC.com, jid=bob@ABC.com.

Resource Optional resource, as specified in RFC 3920. For example "/home". If this 
setting is blank and the Jabber ID includes a resource, the value from that ID is 
used. If both are specified, the value from this Resource field is used.
If no resource is specified, the XMPP server will assign a temporary resource.

Priority The priority, as per RFC 3921. The default is 0.

Table 4: XMPP Account Properties – Account

Field Description
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SIP Account Properties – Account

Table 5: SIP Account Properties – Account

Field Description
Account name If desired, change the account name to something that is meaningful to you. For 

example, the name of the VoIP service provider.
Protocol Read-only. Always specifies SIP.

User Details
User ID Typically the account number for the softphone account plus the domain. For 

example, kpereira@domain.com. Provided by your VoIP service provider.
Password Provided by your VoIP service provider.
Display name This name is displayed in the Bria display.

Other parties will see this name they are when connnected to you.
Authorization user name May not be required. If it is required, it will be provided by your VoIP service 

provider.

Domain Proxy
Register with domain and receive incoming 
calls

Check this box if you want to register with your VoIP service provider, so that 
you can receive incoming calls.
Typically, this field is checked. 
A situation in which this field is unchecked is, for example, if your level of 
service does not include the ability to receive incoming calls. In this case, turning 
this field on may cause registration to fail (when you close the Account 
Properties window), meaning that your Bria cannot register with your VoIP 
service provider.
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Send outbound via Choose the setting specified by your VoIP service provider: 
• Domain: If your VoIP service provider requires that traffic be directed to 

proxies that are discovered via the domain.
• Proxy: If your VoIP service provider has an outbound proxy address and 

requires that you provide the address to Bria. For the address enter a domain 
name (for example, domain.com) or an IP address (for example, 
123.456.789.012). 

Dialing Plan Information about the syntax of the numbers used by this VoIP service provider. 
Provided by the service provider. The default plan is:
#1\a\a.T;match=1;prestrip=2;
It is possible that this plan will work for you. If you can place a successful call, 
then the dialing plan is suitable. If you cannot make a call, or if you want to set 
up a dialing plan for you own reasons, see “Dialing Plan” on page 79. 

Table 5: SIP Account Properties – Account

Field Description
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SIP Account Properties – Voicemail

Complete these settings only if your service provider offers voicemail.
These settings let you set up Bria to forward calls in several situations.
Your service provider may also provide the ability to set up for voicemail outside of Bria, for example, by 
phoning a softphone address and following the voice prompts, or by accessing a website. 
Check with your service provider to determine if another setup mechanism is available. If so, check what the 
settings are in that setup, and make sure you do enter compatible information in Bria.  service provider
 

Table 6: SIP Account Properties – Voicemail

Field Description
Check for voicemail If your VoIP service includes voicemail, choose the setting specified by your 

VoIP service provider.:
• On: Bria will subscribe to be notified when there is a voicemail for you. 
• Off: the service provider may be set up to advise Bria when there is a 

voicemail for you; check with your service provider for details.

If your VoIP service does not include voicemail, choose Off.  

Voicemail is controlled by your VoIP service provider, not by Bria. Contact your 
service provider for information on using voicemail.

Number to dial for checking voicemail Complete only if your VoIP service includes voicemail.
If you leave this field empty, then this icon will not work; you will have to 
manually dial this number in order to connect to voicemail.
Enter the number provided by your VoIP service provider.

Number for sending calls to voicemail Complete only if your VoIP service includes voicemail.
This is the number that incoming calls will be forwarded to if they are 
unanswered after the specified interval (below).
Enter the number provided by your VoIP service provider.
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Send calls to voicemail if unanswered Complete only if your VoIP service includes voicemail.
To send to voicemail after the specified number of seconds. 
Your service provider may also provide a similar feature that is set up outside of 
Bria. If so, make sure you do not enter competing information in Bria and in the 
service provider’s user interface. For example, if you turn off this field, make 
sure the same feature at your service provider is also turned off. Otherwise, all 
your calls will continue to be forwarded.

Always forward to this address You can use this feature even if your VoIP service does not include voicemail.
To always forward phone calls, click the box and enter the address to forward to. 
Phone calls received on other accounts (if you have them) are not affected by 
enabling this field. 

Forward to this address when busy You can use this feature even if your VoIP service does not include voicemail.
To forward only when you are on another phone call, click the box and enter the 
address to forward to. Phone calls received on other accounts (if you have them) 
are not affected by enabling this field. 
Your service provider may provide a similar feature that is set up outside of Bria. 
If so, make sure you do not enter competing information in Bria and in the 
service provider’s user interface. For example, if you turn off this field, make 
surethe same feature at your service provider is also turned off.

Table 6: SIP Account Properties – Voicemail

Field Description
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SIP Account Properties – Topology

Table 7: SIP Account Properties – Topology

Field Description

Firewall Traversal
IP Address This setting controls how your IP address is presented. 

• Discover global address: Let Bria determine your public IP address. This is 
the recommended setting unless your VoIP service provider advises 
otherwise.

• Use local IP address: use the IP address of the Bria computer.

The recommended setting is Discover global address.
STUN Server This setting specifies the STUN server to use.

• Discover the server: Choose this option to let Bria find the address of a STUN 
server. 

• Use this server:  To use a different STUN server. For the address enter a 
domain name or an IP address. 

The recommended setting is Discover server.
Enable ICE ICE optimizes traffic and may help with firewall traversal.

Typically, ICE is enabled. However, it may need to be disabled if your VoIP 
service provider has implemented a firewall traversal solution that is not 
compatible with ICE enabled. 
If you have problems with calls, contact your VoIP service provider for 
information on their firewall traversal solution.

XTunnels
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Use XTunnels The appropriate setting depends on whether your VoIP service provider has an 
XTunnels server. 
• Automatic: Use Xtunnels when Bria detects a firewall that prohibits 

communications. This is the recommended setting if your service provider 
has an XTunnels server.

• Always: Always use XTunnels.
• Never: Do not use XTunnels. This is the correct setting if your service 

provider does not have an XTunnels server.
Server Address Optionally, specify the name or IP address of the XTunnels server to use.

• If the field is completed, Bria will use that server.
• If it is blank, Bria will perform a DNS lookup to discover the server.

Username and Password Check this box to use the username and password from your SIP account in order 
to log into the XTunnels server.
Otherwise, uncheck this box and complete the Username and Password fields.

Range of Ports on Local Computer
Range of ports used on local computer The appropriate setting depends on your computer setup:

• Checked: If your computer is behind a restrictive firewall that only allows 
specific port ranges to be used. Enter the range of ports to use for your SIP 
account. (You must also open those ports on your firewall; refer to applicable 
firewall documentation for information.)

• Unchecked: If your computer is not behind a restrictive firewall.   

File Transfer
Files transfer server Not supported; leave this field blank. This field relates to file transfer via a SIP 

account. Bria supports file transfer via an XMPP account; see page 28.

Table 7: SIP Account Properties – Topology

Field Description
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SIP Account Properties – Presence

Presence allows other softphone users to see your online availability, and also allows you  to see the online 
availability of others. 
This tab lets you set up to share presence information with contacts who have addresses associated with this SIP 
account (for information on account association, see “Contact Profile — Advanced Dialog” on page 33). 
(Note that you do not have to set up to share presence information on an XMPP account.) 
Once you have configured presence on this page, you can set up rules; see “Availability” on page 39 and 
“Preferences – Privacy” on page 50.

Table 8: SIP Account Properties – Presence

Field Description
Mode Choose the setting specified by your VoIP service provider:

• Disabled: Presence is not supported.
• Presence Agent. 
• Peer-to-Peer.

Poll time Enter the value specified by your VoIP service provider. The factory setting is 
300.

Refresh interval Enter the value specified by your VoIP service provider. The factory setting is 
3600.
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SIP Account Properties – Storage

These settings let you set up a remote storage system for the buddy list for this SIP account. (Note that the 
buddy list for an XMPP account is always stored on the XMPP server; no configuration is required).

Table 9: SIP Account Properties – Storage

Field Description
Storage method The storage method to be used for the buddy list and presence rules. The file can 

be stored locally or both locally and on a remote computer.

Server Settings
Use SIP credentials Check this box to use the username and password from your SIP account in order 

to log into the storage server.
Otherwise, uncheck this box and complete the Username and Password fields.
Not used for “Local”.

Root URL URL of an appropriate root folder on the remote server.
Not used for “Local”. The factory setting is https://webdav.$domain$/webdav/
$username$/

WebDAV poll time Enabled only for WebDAV. The time that elapses between polling for new data 
from the remote server.
The factory setting is 600.
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SIP Account Properties – Security

Table 10: SIP Account Properties – Security

Field Description
Signaling Transport Contact your VoIP service provider to identify the types of transport that are 

supported. Then choose a supported transport:
• Automatic: Bria sets up the transport based on the capabilities of the network 

and the Bria computer. Choose this option if you do not care which transport 
is used.

• Encrypted: Currently, this option means TLS will be used. Choose this option 
to request signaling encryption or both signaling and media encryption.

• TCP: This transport provides no signaling security. 
• UDP: This transport provides no signaling security. 
• TLS: Choose this option to request signaling encryption or both signaling and 

media encryption.
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SIP Account Properties – Advanced

s

Table 11: SIP Account Properties – Advanced

Field Description

Register Settings
Reregister every The time interval between Bria’s attempts to reregister in order to refresh the 

account registration with the VoIP service provider for this account. A value of 
zero means not to reregister after the initial registration.
This value is placed in the “Expires” header field of the REGISTER message.
The factory setting is 3600.

Minimum time If the reregistration fails, Bria will wait this amount of time, then attempt to 
reregister. If the second attempt fails, Bria will wait twice this time and try again, 
then four times this time, and so on, until reregistration succeeds.
The factory setting is 20.
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Maximum time This is the maximum wait time between attempts to reregister. Once this 
maximum is reached, Bria will wait this time for all subsequent attempts.
For example, the min. time is 20 secs, the maximum time is 120 secs. Bria will 
attempt to reregister as follows:
• Wait 20 secs.
• Attempt to connect. 
• If fail, wait 40 secs.
• Attempt to connect.
• If fail, wait 80 secs.
• Attempt to connect.
• If fail, wait 120 secs (the maximum)
• Attempt to connect.
• If fail, wait 120 secs, and so on.

The factory setting is 1800.

Timers
Enable session timers
Default session time

A session timer is a mechanism to detect whether a call session is still active 
from the signaling point of view. When the timer expires, a refresh is sent from 
one party to the other. The timer is then reset.
• Turn on to enable session timer. Enter a value in Default session time. The 

factory setting is 60.
• Turn off to disable session timer; refreshes will never be sent.

Session timer preference This field specifies your preference for which party should send the refresh. The 
preference is not a guarantee that the refresh will be performed by the specified 
party. The choices are:
• None: No preference.
• Local refreshes: Your computer sends.
• Remote refreshes: The other party sends.
• UAC refreshes: The user agent client (the party that initiated establishment of 

the  communications) sends.
• UAS refreshes: The user agent server (the other party) sends.

Send SIP keep-alives Typically on, to instruct Bria to send SIP keep-alive messages in order to 
maintain a “pinhole” through your firewall for SIP messaging.

Use rport Typically on.

Table 11: SIP Account Properties – Advanced

Field Description
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A Application Hot Keys
Function Keyboard Shortcut

Answer Enter

Exit Ctrl Q

Hang up Esc

Hold Period

Increase/Decrease Volume Up/Down Arrows

Mute Spacebar
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B Dialing Plan
When a call attempt is made, the call input (what you type, select or drag onto the Call display) is processed to 
select the SIP account to use and to modify the input if that is required to ensure that the call gets placed 
successfully. This ability to select an account and modify the input relies on the existence of a “dialing plan” for 
each account.

The input is processed as follows:

• Cleanup: Input is cleaned up by removing spaces, dashes, open brackets, and close brackets. Cleanup 
allows Bria to support calls placed using contacts from a contact list, including Microsoft® Outlook®.

• Matching: The input is compared to the patterns defined by the dialing plan for each enabled account. Each 
account has one dialing plan, and each dialing plan has one or more patterns.
When a match is found between the input and the pattern, the account that this pattern belongs to is selected 
and the transformation for this pattern is performed.

If no match is found, the default account is selected and no transformation is performed.

For details on matching see “How the Input Is Processed” on page 82.

• Transformation: The selected transformation is performed.
• Then the call is placed using the transformed input. 

The Default Dial Plan
The default dial plan is:

#n\a\a.T;match=1;prestrip=2;

where #n is the account prefix (#1 for the first account in the list (proxy0), #2 for the second account (proxy1), 
and so on).

If the input is the account prefix and the number, then the Account for this dial plan is selected. The account 
prefixed is stripped from the number before the call is placed.

If all Accounts use this dial plan, then the behavior is as follows: if the input includes the account, then that 
account is used. In other words, you can force selection of a specific account by including the account prefix. If 
the input does not include #n, then the default account is used.

Do You Need to Read this Information?
You do not have to read this dial plan information if the default dial plan behavior (above) is acceptable.

If you want to be able to place calls on a specific account without including the account prefix, then you must 
create a dial plan for one or more accounts.
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B.1 Dialing Plan Syntax
In Bria, the dialing plan establishes the expected patterns of characters for a telephone number or softphone 
address, and allows for modification (transformation) of input based on the match to a pattern. The dialing plan 
has the following syntax:

pattern[|pattern];match=1;<transformation>=<value>;[match=2;
<transformation>=<value>;]

Where:

• Items in [ ] are optional. 
• Pattern: the pattern that will be matched. One or more patterns. Each pattern is separated by a | pipe. The 

pipe is optional after the last pattern. Each pattern is implicitly numbered, starting from 1.
• Match; Transformation: A pair that identifies the pattern number to compare with the input, and the 

transformation to perform on the input when a match is obtained. The transformation is optional (meaning 
that if there is no transformation for a pattern, then the input that matches this pattern is not transformed). 
One or more pairs.
“match=” is a literal. “n” identifies the pattern. “transformation=” is replaced by a keyword, see below. 
“value” is replaced by a value.

Spaces are allowed only in the <value> items. 

Example
\a\a.T|xxxxxxxxxx;match=1;prestrip=2;match=2;pre=8;

where:

• \a\a.Tis the first pattern.
• xxxxxxxxxx;is the second pattern.
• match=1;prestrip=2;is the first match-transformation pair.
• match=2;pre=8;is the second match-transformation pair.

Pattern

Valid Content
The content for a pattern follows the digit map rules of RFC 2705, supplemented by the rules for regular 
expressions. Where there is an overlap between the digit map and regular expression rules, the digit map rules 
apply. For this reason, there are some special cases, included in the table below.

The following table describes the most common elements. As mentioned, all regular expression elements are 
supported.

Element Origin Description

0 1 2 3 4 5 6 7 8 9  Literals Literal digits, used as is. 

# * a to z Literals Literal characters, used as is. Special cases: 
• The literal x character is represented by \x.
• The literal t character is represented by \t.

x Digit map rules Wildcard for any single digit, 0 to 9. 
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Timers
There are two timers:

• T timer is 4 seconds.
• The long timer is 20 seconds.

These timers are used in input comparison, as described in “How the Input Is Processed” on page 82.

Transformation Keywords

Order of Transformations
These transformations are always performed in the following order (the order in which the transformations are 
entered in the dialing plan is not significant):

prestrip  >  poststrip  >  pre >  post  >  replace

\a Regular 
expression rules

Wildcard for any single alphanumeric character.

[digit-digit] Regular 
expression rules

A digit within the specified range.

[character-
character]

Regular 
expression rules

A character within the specified range.

[digit1, digit2, 
digit3]

Regular 
expression rules

One of the characters in the collection.

. Digit map rules Repeat the last element 0 or more times. For example, xxxx. means repeat the last x 0 or 
more times, which means this pattern matches three or more digits (not four or more 
digits)! Use of this element results in a pattern with “minimum requirements”. 

T Digit map rules A timeout period will take place before automatic dialing starts.
The T timer forces Bria to wait after a match is made. This timer should always be 
included in , and situations:
• Any pattern that uses the . (dot).  For example, if the pattern is xxxx. then adding a 

timer lets you type three or more digits. If there is no timer, then as soon as you type 
three digits, Bria makes the match as soon as you type three digits. 

• Any dialing plan that has two patterns that are similar in elements but different in 
length. For example, if one pattern is xxx and the other pattern is xxxxxxx, then 
adding the timer lets you continue typing past three digits, in order to get a match on 
the second pattern.

In this situation, the T timer should be included in the shorter pattern. 

Keyword Description

prestrip Strip the first n characters from the input before 
placing the call.

poststrip Remove n number of characters from the end of 
the input before placing the call.

pre Add the specified account prefix to the input 
before placing the call.

post Attach the  specified postfix to the input before 
placing the call.

replace Replaces the input with the specified string 
before placing the call.

Element Origin Description
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B.2 How the Input Is Processed

Comparing Input to the Dialing Plan Patterns
The input is compared to each dialing plan in turn, starting with the first listed account. The process is slightly 
different depending on how the call is placed:

• If the input was dragged or selected, then the entire input is compared to each dialing plan. If a complete 
match is found, then that account is selected and the associated transformation is performed. If no match is 
found, the default account is selected and no transformation is performed. 

• If you are typing the input, the digits are compared one by one as they are entered. The comparison will 
result in one of the types of matches described in the table below.

It is possible for the same input to get matched to different dialing plans depending on whether the input is 
entered on the fly or dragged. It is important to keep this in mind when designing dialing plan patterns.  

Results of the Comparison
Type of Match Conditions Result if You Press 

Enter or Dial
Result if You Stop 

Typing

Partial match The characters typed so far follow the pattern but 
there are not yet enough characters for a pending 
or complete match.

The default account is 
selected. No transformation 
is performed.

If you stop typing for the 
long timer length (20 
seconds), then the default 
account is selected. No 
transformation is performed 
on the characters typed so 
far.

Pending match • The pattern has no . (dot) but does have the T 
timer. There is a perfect match.

• The pattern has a . (dot) and the T timer. The 
minimum requirements are met.

This pattern's account is 
selected and the 
transformation is performed.

If the T timer expires, this 
pattern's account is selected 
and the transformation is 
performed.

Complete match • The pattern has no . (dot) and no T timer. 
There is a perfect match.

• The pattern has a . (dot) but does not have the 
T timer. The minimum requirements are met.

This pattern's account is 
selected and the associated 
transformation is performed.

This pattern's account is 
selected and the associated 
transformation is performed.

No match The characters typed do not match the patterns 
for any dialing plan.

The default account is 
selected and no 
transformation is performed.

Nothing happens even after 
the T timer and long timer 
have expired.
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B.3 Examples

Example 1
\a\a.T|xxxxxxx.T;match=2;pre="9"

This simple example shows how to differentiate between a PSTN number and a softphone address, and how to 
add a “9” dialing prefix only to the PSTN number.  

Example 2
3xxT|1xxxxxxxxxx|[2-9]xxxxxxxxx|+x.T;match=2;pre="9";
match=3;pre="91";match=4;prestrip=1;pre="9011"

Example 3
#1xxxxxxxT|#19xxxxxxx|xxxxxxxT|9xxxxxxx|;match=1;prestrip=2;pre=9;match=2;
prestrip=2;match=3;pre=9;

This example assumes that the dialing plan belongs to the first account. 

The dialing plan is slightly trivial, because it does not cover all the situations that a dialing plan should be 
designed for (local calls, long-distance calls, international calls, and so on for the locale). 

However, the example does illustrate two ideas:

3xxT The first pattern is any three-digit number beginning with 3. No transformation. The 
assumption is that this is an internal extension. The timer forces Bria to wait after detecting a 
three-digit number beginning with 3, in case you are actually dialing a local call starting with 
3. 

1xxxxxxxxxx The second pattern is any eleven-digit number beginning with 1. Prefix with 9 and dial as is. 
The assumption is that this is a long-distance PSTN call within North America (within North 
America, all long-distance calls start with 1).

[2-9]xxxxxxxxx The third pattern is any ten-digit number beginning with a number other than 1. The 
assumption is that this is a local PSTN call within a ten-digit dialing zone. 

+x.T; The fourth pattern is a number of any length that begins with +, to indicate an international 
PSTN call from North America. Delete the +, prefix with 9011 (011 is the number to access 
an international line from North America).

match=2;pre="9"; For the second pattern, prefix 9 to access an outside line.

match=3;pre="91"; For the third pattern, prefix 9 and 1 to access an outside line and enter the long-distance code.

match=4;prestrip=1;pre="9011" For the fourth pattern, remove the + and prefix 9011 to access an outside line and enter the 
international code.

#1xxxxxxxT The pattern is an acount prefix followed by seven digits. The timer forces Bria to wait to 
allow a match to the second pattern. The #1 is stripped off and 9 is prepended to access an 
outside line.

#19xxxxxxx The pattern is an account prefix followed by a 9 and seven digits. The #1 is stripped off.

xxxxxxxT The pattern is seven digits. The timer forces Bria to wait to allow matching to the fourth 
pattern. 9 is prepended to access an outside line.

9xxxxxxx The pattern is a 9 and seven digits. The input is not transformed.
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• Handling of the account prefix (#1), if you are upgrading from Bria 1.1 and are accustomed to entering the 
account number. 
Use of # to identify the account is now deprecated. The dialing plan should be capable of determining the 
account to use for this number. However, since users may still be in the habit of entering the account prefix, 
you may want to include this pattern to handle such a scenario.

• Distinguishing between a local seven-digit call in which 9 is not dialed (to access an outside line) and one 
in which 9 is dialed to access an outside line.  
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C Contact List Headings
Following is a list of all the headings that are used in the Bria contact list. This list can be useful when 
formatting a contact list in order to import it into Bria. For details, see “Importing Contacts” on page 34

uri business_number sms_addresss

display-name business_number2 ms_address2

entry_id business_number3 sms_address3

given_name business_number4 sms_address4

surname business_number5 sms_address5

email_address business_number6 sms_address6

email_address2 mobile_number custom_fields

email_address3 mobile_number2 custom_fields2

email_address4 mobile_number3 custom_fields3

email_address5 mobile_number4 custom_fields4

email_address6 mobile_number5 pres_subscription

sip_address mobile_number6

sip_address2 fax_number

sip_address3 fax_number2

sip_address4 fax_number3

sip_address5 fax_number4

sip_address6 fax_number5

home_number fax_number6

home_number2 groups

home_number3 comment

home_number4 postal_address

home_number5 default_address

home_number6 default_address_type
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D Location of Files
System files get copied to the installation directory specified when installing Bria. The default installation 
directory is:

C:\Program Files\CounterPath\Bria

Data files are saved in the Counterpath folder in the standard location for application data, as defined in 
Windows.This location is typically: 

C:\Documents and Settings\<user name>\Application Data\CounterPath 
Solutions Inc\Bria\
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E Other Ways to Run Bria 

E.1 From a Hyperlink
You can attach a hyperlink to a phone number or softphone address that, when clicked, starts Bria and dials the 
number. Attach a hyperlink with this format:

<a href="sip:<address or number>">dial <address or number></a>

For example:

<a href="sip:kpereira@domain.com">dial kpereira@domain.com</a>

E.2 From the Command Line
You can start Bria from a DOS prompt. You may need to add Bria.exe to the PATH. Then type:

Bria.exe

To start Bria from a DOS prompt and immediately dial a number, type:

Bria.exe -dial=sip:<number>
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F Glossary
AEC Acoustic echo cancellation. Processing of the audio or video signal to reduce the echo 

effect that can arise with a speakerphone or that can arise if the sound from the 
speakerphone or headphone leaks into the microphone. 

AGC Automatic gain control. Processing of the audio or video signal to adjust the 
microphone volume level so that the other party does not hear the distortion that 
might be caused by too high a microphone input or too low volume (due to too low 
input level).

AVI Audio Video Interleave. A multimedia container format. AVI files contain both audio 
and video data in a standard container that allows simultaneous playback.

Broadband Broad or wide bandwidth. In data transmission, the wider the band, the more data it is 
possible to transmit in a given time span. A cable, DSL and ADSL connection to the 
network provide broadband for data transmission. A dialup or ISDN connection 
typically provide a narrow bandwidth for data transmission.

Codec The format by which audio or video streams are compressed for transmission over 
networks.

Default account The SIP account that will be used when placing an outgoing call, if Bria does not 
determine that another account should be used. Bria uses the dialing plan to determine 
the account to use. You can mark one account as the default account; see “Setting the 
Default Account” on page 63.

Dialing plan The rules that Bria follows in order to interpret the softphone address or phone 
number that the user has entered and to modify the number or address, as required, to 
ensure that the call will be placed successfully. 

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-
response menu systems such as the menu system for accessing voicemail messages. 
The DTMF system allows the user to interact with the menu by pressing keys on a 
dialpad or keyboard.

IM Instant Messaging. A technology that lets users send text message and files for near 
instantaneous delivery and display on each others’ computers.

IP Internet Protocol. A data-oriented protocol used for communicating data across a 
network. IP is the most common protocol used on the internet.

IP address A unique number that devices use in order to identify and communicate with each 
other on a computer network using the IP standard. 

Media In a VoIP phone call, the audio and video portion of the information in a call. 
Compare to “Signaling”.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the 
owner of an account.

Narrowband In data transmission, the wider the band, the more data it is possible to transmit in a 
given time span. A cable, DSL and ADSL connection to the network provide 
broadband for data transmission. A dialup or ISDN connection typically provide a 
narrow bandwidth for data transmission.

Presence An instant messaging feature that allows users to share information about their 
availability, mood, location and so on.

Proxy See SIP account.
PSTN Public Switch Telephone Network. The traditional land-line phone network.
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RFC Request for Comment. A document that describes an aspect of an internet technology. 
An RFC may be a proposed, draft or full internet standard.

RTP Real-time Transport Protocol. A protocol for delivering the media portion of a data 
transmission over an IP network. SRTP is another media protocol.

Signaling In a VoIP phone call, the information in a call that deals with establishing and 
controlling the connection, and managing the network. The non-signaling portion of 
the call is the Media.

SIMPLE protocol Session Initiation Protocol for Instant Messaging and Presence Leveraging 
Extensions. The instant messaging (IM) protocol followed by Bria. It encapsulate the 
rules for exchanging instant messages.

SIP Session Initiation Protocol. The signaling protocol followed by Bria for handling 
phone calls. 

SIP account An account that provides the user the ability to make VoIP phone calls. The account 
encapsulates the rules and functions the user can access.

softphone address The address used to connect to a SIP endpoint. In other words, the “phone number” 
used in a VoIP phone call. For example, sip:joseph@domainA.com.

SRTP Secure Real-time Transport Protocol. A protocol for delivering the media portion of a 
data transmission over an IP network. SRTP is a secure protocol, which means that 
the media is encrypted. RTP is another media protocol.

TCP Transmission Control Protocol. A transport protocol for delivering data over an IP 
network. Other transport protocols are TLS and UDP.

TLS Transport Layer Security. A transport protocol for delivering data over an IP network. 
TLS is a secure transport protocol, which means that all the data being transmitted 
(signaling and media) is encrypted. Other transport protocols are TCP and UDP.

UDP User Datagram Protocol. A transport protocol for delivering data over an IP network. 
Other transport protocols are TCP and TLS.

URI Uniform Resource Identifier. A name or address that identifies a location on the world 
wide web. A softphone address is a type of URI.

URL Uniform Resource Locator. A URI that both identifies a name or address and indicates 
how to locate it. 

USB device Universal Serial Bus device. A device that follows a specific communications 
standard. A headset may be a “USB type” of headset. 

VAD Voice Activity Detection. A technology that detects if audio is a human voice or 
background noise. Bria includes a feature (Preserve bandwidth on the Network panel 
of the Preferences window) that controls whether audio is transmitted when VAD 
determines that none is actually speaking.

vCard An electronic business card that is often attached to an email. It often appears as a 
“signature” block that identifies the person, their title, and their business.

VoIP Voice over Internet Protocol. A variation of IP used for sending voice data over the 
internet, in other words, used for making phone calls over the internet.

VoIP service provider A business that provides a VoIP service, allowing a user to connect to the internet in 
order to make VoIP phone calls using Bria. The VoIP service provider sets up a SIP 
account for the user. 

WAV Or WAVE. A file format standard for storing audio on PCs.


